$re = '/.*\bdiscover\b.*/mi';
$str = 'this has discover in it
discover
discover
looks like a discovery
Discover
ends with discover
something discovery something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);