re = /.*\bdiscover\b.*/mi
str = 'this has discover in it
discover
discover
looks like a discovery
Discover
ends with discover
something discovery something'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end