package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.{21}print[^/]{49}o.{7}$`)
var str = `{n in for j in 0..<n{print((1...n).map{j%2==0 ?$0+j*n:j*n+n+1-$0})}} as(CShort)->()`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}