const regex = /^.{21}print[^/]{49}o.{7}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.{21}print[^\/]{49}o.{7}$', 'g')
const str = `{n in for j in 0..<n{print((1...n).map{j%2==0 ?\$0+j*n:j*n+n+1-\$0})}} as(CShort)->()`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}