re = /^.{21}print[^\/]{49}o.{7}$/
str = '{n in for j in 0..<n{print((1...n).map{j%2==0 ?$0+j*n:j*n+n+1-$0})}} as(CShort)->()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end