const regex = /^(?=\S{8})(?!\S*@\S*\.\S*\.)[a-zA-Z]\S*(?:@\S+\.\S+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\S{8})(?!\\S*@\\S*\\.\\S*\\.)[a-zA-Z]\\S*(?:@\\S+\\.\\S+)?$', 'gm')
const str = `user@user.com
adminuser1
user.user@user.com
Invalid:
user@user.user.com
1adminuser1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}