re = /^(?=\S{8})(?!\S*@\S*\.\S*\.)[a-zA-Z]\S*(?:@\S+\.\S+)?$/m
str = 'user@user.com
adminuser1
user.user@user.com
Invalid:
user@user.user.com
1adminuser1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end