import re
regex = re.compile(r"^(?=\S{8})(?!\S*@\S*\.\S*\.)[a-zA-Z]\S*(?:@\S+\.\S+)?$", flags=re.MULTILINE)
test_str = ("user@user.com\n"
"adminuser1\n"
"user.user@user.com\n\n"
"Invalid: \n"
"user@user.user.com\n"
"1adminuser1\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")