import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|.*?(\\d{1,8})$|([a-zA-Z]+[\\d_-]{1,8}[a-zA-Z]+))";
final String string = "H2K 101\n"
+ "HKK 101\n"
+ "aZ1_-xyz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}