$re = '/(?|.*?(\d{1,8})$|([a-zA-Z]+[\d_-]{1,8}[a-zA-Z]+))/m';
$str = 'H2K 101
HKK 101
aZ1_-xyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);