// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?|.*?(\d{1,8})$|([a-zA-Z]+[\d_-]{1,8}[a-zA-Z]+))").unwrap();
let string = "H2K 101
HKK 101
aZ1_-xyz";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}