using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^(?:.+)?(?:facebook|fb).(?:[a-z\.]{2,6})(/pages|/pg|/group[s])?/([^/]+)(?:/|$)";
string input = @"https://www.facebook.com/groups/330664430790820/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}