$re = '/(?i)^(?:.+)?(?:facebook|fb).(?:[a-z\.]{2,6})(/pages|/pg|/group[s])?/([^/]+)(?:/|$)/';
$str = 'https://www.facebook.com/groups/330664430790820/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);