package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^(?:.+)?(?:facebook|fb).(?:[a-z\.]{2,6})(/pages|/pg|/group[s])?/([^/]+)(?:/|$)`)
var str = `https://www.facebook.com/groups/330664430790820/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}