#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\r\n].*?)(?:=?\r|\n)(.*?(?:14393).*)"
Local $sString = "<tr>" & @CRLF & _
"<td>CBB <span> • </span> CB <span> • </span> LTSB</td>" & @CRLF & _
"<td>2022-09-13</td>" & @CRLF & _
"<td>14393.5356</td>" & @CRLF & _
"<td><a href="https://support.microsoft.com/help/5017305" target="_blank" data-linktype="external">KB5017305</a></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td>CBB <span> • </span> CB <span> • </span> LTSB</td>" & @CRLF & _
"<td>2022-08-09</td>" & @CRLF & _
"<td>14393.5291</td>" & @CRLF & _
"<td><a href="https://support.microsoft.com/help/5016622" target="_blank" data-linktype="external">KB5016622</a></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td>CBB <span> • </span> CB <span> • </span> LTSB</td>" & @CRLF & _
"<td>2022-07-12</td>" & @CRLF & _
"<td>14393.5246</td>" & @CRLF & _
"<td><a href="https://support.microsoft.com/help/5015808" target="_blank" data-linktype="external">KB5015808</a></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td>CBB <span> • </span> CB <span> • </span> LTSB</td>" & @CRLF & _
"<td>2022-06-14</td>" & @CRLF & _
"<td>14393.5192</td>" & @CRLF & _
"<td><a href="https://support.microsoft.com/help/5014702" target="_blank" data-linktype="external">KB5014702</a></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")