import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\r\\n].*?)(?:=?\\r|\\n)(.*?(?:14393).*)";
final String string = "<tr>\n"
+ "<td>CBB <span> • </span> CB <span> • </span> LTSB</td>\n"
+ "<td>2022-09-13</td>\n"
+ "<td>14393.5356</td>\n"
+ "<td><a href=\"https://support.microsoft.com/help/5017305\" target=\"_blank\" data-linktype=\"external\">KB5017305</a></td>\n"
+ "</tr>\n"
+ "<tr>\n"
+ "<td>CBB <span> • </span> CB <span> • </span> LTSB</td>\n"
+ "<td>2022-08-09</td>\n"
+ "<td>14393.5291</td>\n"
+ "<td><a href=\"https://support.microsoft.com/help/5016622\" target=\"_blank\" data-linktype=\"external\">KB5016622</a></td>\n"
+ "</tr>\n"
+ "<tr>\n"
+ "<td>CBB <span> • </span> CB <span> • </span> LTSB</td>\n"
+ "<td>2022-07-12</td>\n"
+ "<td>14393.5246</td>\n"
+ "<td><a href=\"https://support.microsoft.com/help/5015808\" target=\"_blank\" data-linktype=\"external\">KB5015808</a></td>\n"
+ "</tr>\n"
+ "<tr>\n"
+ "<td>CBB <span> • </span> CB <span> • </span> LTSB</td>\n"
+ "<td>2022-06-14</td>\n"
+ "<td>14393.5192</td>\n"
+ "<td><a href=\"https://support.microsoft.com/help/5014702\" target=\"_blank\" data-linktype=\"external\">KB5014702</a></td>\n"
+ "</tr>\n"
+ "<tr>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}