import re
regex = re.compile(r"([\r\n].*?)(?:=?\r|\n)(.*?(?:14393).*)", flags=re.MULTILINE)
test_str = ("<tr>\n"
"<td>CBB <span> • </span> CB <span> • </span> LTSB</td>\n"
"<td>2022-09-13</td>\n"
"<td>14393.5356</td>\n"
"<td><a href=\"https://support.microsoft.com/help/5017305\" target=\"_blank\" data-linktype=\"external\">KB5017305</a></td>\n"
"</tr>\n"
"<tr>\n"
"<td>CBB <span> • </span> CB <span> • </span> LTSB</td>\n"
"<td>2022-08-09</td>\n"
"<td>14393.5291</td>\n"
"<td><a href=\"https://support.microsoft.com/help/5016622\" target=\"_blank\" data-linktype=\"external\">KB5016622</a></td>\n"
"</tr>\n"
"<tr>\n"
"<td>CBB <span> • </span> CB <span> • </span> LTSB</td>\n"
"<td>2022-07-12</td>\n"
"<td>14393.5246</td>\n"
"<td><a href=\"https://support.microsoft.com/help/5015808\" target=\"_blank\" data-linktype=\"external\">KB5015808</a></td>\n"
"</tr>\n"
"<tr>\n"
"<td>CBB <span> • </span> CB <span> • </span> LTSB</td>\n"
"<td>2022-06-14</td>\n"
"<td>14393.5192</td>\n"
"<td><a href=\"https://support.microsoft.com/help/5014702\" target=\"_blank\" data-linktype=\"external\">KB5014702</a></td>\n"
"</tr>\n"
"<tr>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")