# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b-\b/\n/gm;t' <<< "dfwx--05-dfpixc3-dfwx--8-dfpixc3"