$re = '/\b-\b/m';
$str = 'dfwx--05-dfpixc3-dfwx--8-dfpixc3';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;