use strict;
my $str = 'dfwx--05-dfpixc3-dfwx--8-dfpixc3';
my $regex = qr/\b-\b/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";