package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+|^`)
var str = `12345
the line above matches at the start-of-line
and each of these words match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}