re = /\w+|^/m
str = '12345
the line above matches at the start-of-line
and each of these words match'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end