$re = '/\w+|^/m';
$str = '12345
the line above matches at the start-of-line
and each of these words match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);