#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)ip address dhcp(?!.+ip routing)"
Local $sString = "aa" & @CRLF & _
"ip address dhcp" & @CRLF & _
"" & @CRLF & _
"a" & @CRLF & _
"ip routing" & @CRLF & _
"aa" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")