re = /(?s)ip address dhcp(?!.+ip routing)/
str = 'aa
ip address dhcp
a
ip routing
aa
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end