$re = '/(?s)ip address dhcp(?!.+ip routing)/';
$str = 'aa
ip address dhcp
a
ip routing
aa
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);