#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?)( ?\1)+$"
Local $sString = "HelloHelloHelloHelloHelloHello" & @CRLF & _
"" & @CRLF & _
"Hello this is a repeated pattern Hello this is a repeated pattern Hello this is a repeated pattern Hello this is a repeated pattern" & @CRLF & _
"" & @CRLF & _
"Hello" & @CRLF & _
"Hello" & @CRLF & _
"" & @CRLF & _
"Hello I'm Matheo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")