re = /^(.*?)( ?\1)+$/m
str = 'HelloHelloHelloHelloHelloHello
Hello this is a repeated pattern Hello this is a repeated pattern Hello this is a repeated pattern Hello this is a repeated pattern
Hello
Hello
Hello I\'m Matheo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end