$re = '/^(.*?)( ?\1)+$/m';
$str = 'HelloHelloHelloHelloHelloHello
Hello this is a repeated pattern Hello this is a repeated pattern Hello this is a repeated pattern Hello this is a repeated pattern
Hello
Hello
Hello I\'m Matheo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);