package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{4})`)
var str = `4581458245834584`
var substitution = "-\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}