$re = '/(\d{4})/';
$str = '4581458245834584';
$subst = "-\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;