use strict;
my $str = '4581458245834584';
my $regex = qr/(\d{4})/p;
my $subst = '-\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";