#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:\+|00)33[\s.-]{0,3}(?:\(0\)[\s.-]{0,3})?|0)[\s.-]?[1-9](?:(?:[\s.-]?\d{1}){8}|\d{2}(?:[\s.-]?\d{3}){2})$"
Local $sString = "French Phone Number Validation." & @CRLF & _
"Accept several kind of format, more or less usual. And refuse incorrect formats." & @CRLF & _
" - Prefix: 0033 / +33 / (0) / 0" & @CRLF & _
" - Number: collapsed / by 1 / group by 2 / group by 3" & @CRLF & _
" - Separator: space / dot / dash / hyphen" & @CRLF & _
"" & @CRLF & _
"~ Accepted ~" & @CRLF & _
"0123456789" & @CRLF & _
"01 23 45 67 89" & @CRLF & _
"01.23.45.67.89" & @CRLF & _
"0123 45.67.89" & @CRLF & _
"0033 123-456-789" & @CRLF & _
"0033(0)123456789" & @CRLF & _
"+33-1.23.45.67.89" & @CRLF & _
"+33 - 123 456 789" & @CRLF & _
"+33(0) 123 456 789" & @CRLF & _
"+33 (0)123 45 67 89" & @CRLF & _
"+33 (0)1 2345-6789" & @CRLF & _
"+33(0) - 123456789" & @CRLF & _
"" & @CRLF & _
"~ Rejected ~" & @CRLF & _
"012345678" & @CRLF & _
"01234567890" & @CRLF & _
"0+123456789" & @CRLF & _
"(0)123456789" & @CRLF & _
"01 23 45 67 89" & @CRLF & _
"" & @CRLF & _
"~ Accepted but strange ~" & @CRLF & _
"+33.-.123456789" & @CRLF & _
"+33.-.(0)-.-123456789" & @CRLF & _
"01 23.45-67.89" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")