import Foundation
let pattern = #"^(?:(?:\+|00)33[\s.-]{0,3}(?:\(0\)[\s.-]{0,3})?|0)[\s.-]?[1-9](?:(?:[\s.-]?\d{1}){8}|\d{2}(?:[\s.-]?\d{3}){2})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
French Phone Number Validation.
Accept several kind of format, more or less usual. And refuse incorrect formats.
- Prefix: 0033 / +33 / (0) / 0
- Number: collapsed / by 1 / group by 2 / group by 3
- Separator: space / dot / dash / hyphen
~ Accepted ~
0123456789
01 23 45 67 89
01.23.45.67.89
0123 45.67.89
0033 123-456-789
0033(0)123456789
+33-1.23.45.67.89
+33 - 123 456 789
+33(0) 123 456 789
+33 (0)123 45 67 89
+33 (0)1 2345-6789
+33(0) - 123456789
~ Rejected ~
012345678
01234567890
0+123456789
(0)123456789
01 23 45 67 89
~ Accepted but strange ~
+33.-.123456789
+33.-.(0)-.-123456789
01 23.45-67.89
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)