use strict;
my $str = 'French Phone Number Validation.
Accept several kind of format, more or less usual. And refuse incorrect formats.
- Prefix: 0033 / +33 / (0) / 0
- Number: collapsed / by 1 / group by 2 / group by 3
- Separator: space / dot / dash / hyphen
~ Accepted ~
0123456789
01 23 45 67 89
01.23.45.67.89
0123 45.67.89
0033 123-456-789
0033(0)123456789
+33-1.23.45.67.89
+33 - 123 456 789
+33(0) 123 456 789
+33 (0)123 45 67 89
+33 (0)1 2345-6789
+33(0) - 123456789
~ Rejected ~
012345678
01234567890
0+123456789
(0)123456789
01 23 45 67 89
~ Accepted but strange ~
+33.-.123456789
+33.-.(0)-.-123456789
01 23.45-67.89
';
my $regex = qr/^(?:(?:\+|00)33[\s.-]{0,3}(?:\(0\)[\s.-]{0,3})?|0)[\s.-]?[1-9](?:(?:[\s.-]?\d{1}){8}|\d{2}(?:[\s.-]?\d{3}){2})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}