#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^000[0-9]{6}$"
Local $sString = "a00812645" & @CRLF & _
"000011000" & @CRLF & _
"111999999" & @CRLF & _
"000000000" & @CRLF & _
"00015427d" & @CRLF & _
"000124574" & @CRLF & _
"102145112" & @CRLF & _
"ajrcjdord" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")