using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^000[0-9]{6}$";
string input = @"a00812645
000011000
111999999
000000000
00015427d
000124574
102145112
ajrcjdord
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}