$re = '/^000[0-9]{6}$/m';
$str = 'a00812645
000011000
111999999
000000000
00015427d
000124574
102145112
ajrcjdord
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);