#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\-]?(?:\d{0,2})[\.]?(?:[\d]{1})$"
Local $sString = "0.23455465" & @CRLF & _
"4.54656" & @CRLF & _
"-334343" & @CRLF & _
"-.34234234" & @CRLF & _
"234234.4234234" & @CRLF & _
"23123" & @CRLF & _
"323-312312" & @CRLF & _
"-12121.34344" & @CRLF & _
"asdasd" & @CRLF & _
"2312" & @CRLF & _
"213.3213.3213" & @CRLF & _
"1.4" & @CRLF & _
"221.4" & @CRLF & _
"-22.4" & @CRLF & _
"22" & @CRLF & _
".4" & @CRLF & _
"1.0" & @CRLF & _
"99.0" & @CRLF & _
"-999" & @CRLF & _
"f.3" & @CRLF & _
"100.2" & @CRLF & _
"100" & @CRLF & _
"234.3" & @CRLF & _
"2" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")