re = /^[\-]?(?:\d{0,2})[\.]?(?:[\d]{1})$/m
str = '0.23455465
4.54656
-334343
-.34234234
234234.4234234
23123
323-312312
-12121.34344
asdasd
2312
213.3213.3213
1.4
221.4
-22.4
22
.4
1.0
99.0
-999
f.3
100.2
100
234.3
2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end