#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{1,3}\.){3}\d{1,3}\/\d{1,2}"
Local $sString = "192.168.23.10/27" & @CRLF & _
"10.57.5.253/23" & @CRLF & _
"xxx.34.19.78/18" & @CRLF & _
"172.z6.10.1/21" & @CRLF & _
"10.57.4.35" & @CRLF & _
"172.16.10.1/20" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")