import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{1,3}\\.){3}\\d{1,3}\\/\\d{1,2}";
final String string = "192.168.23.10/27\n"
+ "10.57.5.253/23\n"
+ "xxx.34.19.78/18\n"
+ "172.z6.10.1/21\n"
+ "10.57.4.35\n"
+ "172.16.10.1/20\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}