re = /^(\d{1,3}\.){3}\d{1,3}\/\d{1,2}/m
str = '192.168.23.10/27
10.57.5.253/23
xxx.34.19.78/18
172.z6.10.1/21
10.57.4.35
172.16.10.1/20
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end