use strict;
my $str = '<id>SomeID</id>
<datasource>C:/projects/my_project/my_file.jpg</datasource>
<title>My title can include / and other characters</title>
<abstract></abstract>';
my $regex = qr~(?:<datasource>[^/]*?|.*(?=<datasource>)|(?=</datasource>).*)(*SKIP)(*FAIL)|/~sp;
my $subst = '\\\\';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";