# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:<datasource>[^/]*?|.*(?=<datasource>)|(?=</datasource>).*)(*SKIP)(*FAIL)|/"
test_str = ("<id>SomeID</id>\n"
"<datasource>C:/projects/my_project/my_file.jpg</datasource>\n"
"<title>My title can include / and other characters</title>\n"
"<abstract></abstract>")
subst = "\\\\"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.