re = /(?:<datasource>[^\/]*?|.*(?=<datasource>)|(?=<\/datasource>).*)(*SKIP)(*FAIL)|\//
str = '<id>SomeID</id>
<datasource>C:/projects/my_project/my_file.jpg</datasource>
<title>My title can include / and other characters</title>
<abstract></abstract>'
subst = '\\\\'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result