package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([ :,])\s+`)
var str = `"Field A: result xyz, Field B: result123, Field C: and this is another result "`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}