$re = '/([ :,])\s+/m';
$str = '"Field A: result xyz, Field B: result123, Field C: and this is another result "';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);