re = /([ :,])\s+/m
str = '"Field A: result xyz, Field B: result123, Field C: and this is another result "'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end