#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-Z]"
Local $sString = "I will always remember" & @CRLF & _
"The day you kissed my lips" & @CRLF & _
"Light as a feather" & @CRLF & _
"And it went just like this" & @CRLF & _
"No, it's never been better" & @CRLF & _
"Than the summer of 2002 (ooh)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")